PHP 5.2 en Ubuntu Lucid (Downgrade)

Enviado por keopx el Vie, 02/07/2010 - 17:54

Tras la actualización a Ubuntu 10.04, nos ha traído algún que otra incompatibilidad en el código php de algunas aplicaciones, algunas de ellas relacionadas con Drupal. Vamos a ver como tener una versión anterior de php.

#!/bin/sh
# Script to install PHP 5.2 from 9.10 on 10.04
# And pin it so it does not get updated
PKGS=`dpkg -l | grep php | awk '{print $2}'`
apt-get remove $PKGS
sed s/lucid/karmic/g /etc/apt/sources.list |
tee /etc/apt/sources.list.d/karmic.list
mkdir -p /etc/apt/preferences.d/
for PACKAGE in $PKGS
do
echo "Package: $PACKAGE
Pin: release a=karmic
Pin-Priority: 991
" | tee -a /etc/apt/preferences.d/php
done
apt-get update
apt-get install $PKGS

Hora ya tendremos los repositorios de karmic para la el php que contiene la version 5.2 Referencias:

Categoria

Añadir nuevo comentario

El contenido de este campo se mantiene privado y no se mostrará públicamente.

HTML Restringido

  • Etiquetas HTML permitidas: <a href hreflang> <em> <strong> <cite> <blockquote cite> <code> <ul type> <ol start type> <li> <dl> <dt> <dd> <h2 id> <h3 id> <h4 id> <h5 id> <h6 id>
  • Saltos automáticos de líneas y de párrafos.
  • Las direcciones de correos electrónicos y páginas web se convierten en enlaces automáticamente.