Excluir paquetes instalados de las actualizaciones en GNU/Linux Debian

Enviado por keopx el Sáb, 03/07/2010 - 18:02

Cuando estamos en una versión deseada de un paquete, como puede ser php, nos interesa que esos paquetes no se actualicen. Para ello instalamos un paquete nuevo:

sudo apt-get install wajig

Paquetes que deseamos bloquear/congelar para que no se actualicen:

sudo wajig hold package

Para saber que paquetes estan bloquedos/congelados:

sudo wajig list-hold

Y para descongelar dichos paquetes:

sudo wajig unhold package

PHP 5.2 en Ubuntu Lucid (Downgrade)

Enviado por keopx el Vie, 02/07/2010 - 17:54

Tras la actualización a Ubuntu 10.04, nos ha traído algún que otra incompatibilidad en el código php de algunas aplicaciones, algunas de ellas relacionadas con Drupal. Vamos a ver como tener una versión anterior de php.

Configurar GDM 2 en Ubuntu

Enviado por keopx el Jue, 01/07/2010 - 16:48

Tras el cambio de diseño no se puede personalizar de forma sencilla el gestor de arraque de Gnome. Para ello existe una herramienta, llamada gdm2setup: Añadir repositorio:

sudo add-apt-repository ppa:gdm2setup/gdm2setup

O también desde Karmic añadir a el fichero /etc/apt/sources.list las lineas:

Redimensionar imagenes en Debian/Ubuntu

Enviado por keopx el Mar, 29/06/2010 - 16:29

Lo primero es necesario el instalar el programa para tratar las imagenes:

sudo apt-get install imagemagick

Redimensionar en base a la altura:

convert foto1.jpg -resize 400x resultado.jpg

Redimensionar en base a la anchura:

convert foto1.jpg -resize x300 resultado.jpg

Para más opciones consultar el man de imagemagick.

Controlar el disco duro con smartmontools en Debiab/Ubuntu

Enviado por keopx el Dom, 27/06/2010 - 15:55

Si se detecta un posible fallo en el disco duro (HD) que nos pudiera dar más fallos tenemos la posibilidad de saber del estado del HD para cambiarlo antes de que se nos termine de "morir".

Para ello es necesario instalar smartmontools:

sudo aptitude install smartmontools

Activamos la monitorización de discos:

Bloquear paquetes para que no se actualicen en Debian/Ubuntu

Enviado por keopx el Mié, 02/06/2010 - 12:18

Tras la instalación de una versión anterior de php es necesario mantenerlos en dicha versión. Para ello vamos a utilizar otro programa para que esto se mantenga así. Instalamos wajig:

$ sudo apt-get install wajig

Instalacion de php 5.2.x en Debian Testing (squeeze)

Enviado por keopx el Mar, 01/06/2010 - 15:17

Para poder funcionar correctamente con Drupal 6.x es necesario el tener una versión anterior a la existente en el repositorio. En este caso es necesario la instalación de la versión de 5.2.x de php. Para ello es necesario desactualizar o eliminar todos los paquetes de php que tengamos. Creamos el siguiente script.

sudo nano quitar_php.sh

Apache SSL y mod_jk

Enviado por keopx el Mié, 12/05/2010 - 18:22

Apache SSL y mod_jk

Introducción

Veremos como conectar Apache y Tomcat con soporte para SSL. La configuración de esta versión esta realizada sobre Apache 2 y Tomcat 6 pero seria igualmente para Apache 2 y Tomcat 5.5.

Instalar APC y Memcache para Drupal

Enviado por keopx el Jue, 29/04/2010 - 12:23

APC

Instalamos el paquete de apc para php5

$ sudo aptitude install php-apc

Memcache

Servidor de memcache

$ sudo aptitude install memcached

Memcache para php5

El modulo por defecto del php5-memcache de fallos y parece que según el CVS para la siguiente versión va estar corregido.